|
Home | Switchboard | Unix Administration | Red Hat | TCP/IP Networks | Neoliberalism | Toxic Managers |
(slightly skeptical) Educational society promoting "Back to basics" movement against IT overcomplexity and bastardization of classic Unix |
|
|
The text below is adapted from IBM AIX Certification Guide
At IPL time, the /init process will run /etc/rc.tcpip after starting the SRC. The /etc/rc.tcpip file is a shell script that, when executed, uses SRC commands to initialize selected daemons. It can also be executed at any time from the command line.
Most of the daemons that can be initialized by the rc.tcpip file are specific to TCP/IP. These daemons are:
inetd (started by default) |
gated |
routed |
named |
timed |
rwhod |
Note: Running the gated and routed daemons at the same time on a host may cause unpredictable results.
There are also daemons specific to the base operating system or to other applications that can be started through the rc.tcpip file. These daemons are:
lpd |
portmap |
sendmail |
syslogd (started by default) |
In daemons started from rc.tcpip can be stopped using the stopsrc command and restarted using the startsrc command.
startsrc -g group_of_daemons
startsrc -s subsystem_daemon
Eg. startsrc -g spooler
startsrc -s lpd
SEE man startsrc
Also see stopsrc
The script /etc/tcp.clean can be used to stop TCP/IP daemons. It will stop the following daemons and remove the /etc/locks/lpd TCP/IP lock files:
ndpd-host |
lpd |
routed |
gated |
sendmail |
inetd |
named |
timed |
rwhod |
iptrace |
snmpd |
rshd |
rlogind |
telnetd |
syslogd |
The /etc/rc.tcpip script can be used to restart TCP/IP daemons. Alternatively, you can use the startsrc -s command to start individual TCP/IP daemons.
Note: Do not restart TCP/IP daemons using the command:
startsrc -g tcpip
It will start all subsystems defined in the ODM for the tcpip group, which includes both routed and gated.
Connections using TCP/IP are often peer-to-peer. There are no master/slave relations. The applications, however, use a client/server model for communications.
Removing the rc.tcpip entry in /etc/inittab means that you are not starting any server applications during IPL.
Note: If you have a graphic console, make sure you also remove the rc.dt and rc.tcpip entries in the /etc/inittab file. Otherwise, your console will hang when you login. Unless you have an ASCII terminal connected to the serial port, there is no way you can recover since you will not be able to communicate with the machine through the telnet or rlogin commands with no TCP/IP server application started.
Without the server applications started, you will not be able to telnet or ftp to this machine from another host.
However, as long as you have not brought down the network interface, you can still utilize the client network services. You can still ping other hosts, you can still telnet to other hosts, and you can still ftp to other hosts.
The ping command sends an Internet Control Message Protocol (ICMP) ECHO_REQUEST to obtain an ICMP ECHO_RESPONSE from a host and does not need a server application. Therefore, even without starting any server application, the machine will still respond to a ping request from other hosts.
The /usr/sbin/inetd daemon provides Internet service management for a network. This daemon reduces system load by invoking other daemons only when they are needed and by providing several simple Internet services internally without invoking other daemons.
When the daemon starts, it reads its configuration information from the file specified in the Configuration File parameter. If the parameter is not specified, the inetd daemon reads its configuration information from the /etc/inetd.conf file. Once started, the inetd daemon listens for connections on certain Internet sockets in the /etc/inetd.conf and either handles the service request itself or invokes the appropriate server once a request on one of these sockets is received.
The /etc/inetd.conf file can be updated by using the System Management Interface Tool (SMIT), the System Resource Controller (SRC), or by editing the /etc/inetd.conf.
If you change the /etc/inetd.conf using SMIT, then the inetd daemon will be refreshed automatically and will read the new /etc/inetd.conf file. If you change the file using an editor, run the refresh -s inetd or kill -1 InetdPID commands to inform the inetd daemon of the changes to its configuration file. You will not receive a message if you use the kill -1 command as shown in
The inetd daemon is a subsystem that controls the following daemons (subservers):
comsat daemon ftpd daemon fingerd daemon rlogind daemon rexecd daemon rshd daemon talkd daemon telnetd daemon tftpd daemon uucpd daemon
The ftpd, rlogind, rexecd, rshd, talkd, telnetd, and uucpd daemons are started by default. The tftpd, fingerd, and comsat daemons are not started by default.
To start any one of them, remove the pound (#) sign in column one of the respective entry in the /etc/inetd.conf file. You can check the details of subservers started in inetd by using the lssrc -ls command, as shown
The /etc/services file contains information about the known services used in the network by inetd. Each service listed in /etc/services runs on a specific port number for communications, in a specific format, such as TCP or UDP.
Each service is listed on a single line corresponding to the form:
ServiceName PortNumber/ProtocolName Aliases
A sample section from /etc/services may look like the following:
echo 7/tcp
echo 7/udp
discard 9/tcp sink null
discard 9/udp sink null
daytime 13/tcp
daytime 13/udp
chargen 19/tcp ttytst source
chargen 19/udp ttytst source
ftp 21/tcp
time 37/tcp timeServer
time 37/udp timeServer
If you edit the /etc/services file, run the refresh -s inetd command, in order for your changes to be used.
The portmap daemon converts remote procedure call (RPC) program numbers into Internet port numbers.
When an RPC server starts up, it registers with the portmap daemon. The server tells the daemon which port number it is listening to and which RPC program numbers it serves. Thus, the portmap daemon knows the location of every registered port on the host and which programs are available on each of these ports.
A client consults the portmap daemon only once for each program the client tries to call. The portmap daemon tells the client which port to send the call to. The client stores this information for future reference.
Since standard RPC servers are normally started by the inetd daemon, the portmap daemon must be started before the inetd daemon is invoked.
Note: If the portmap daemon is stopped or comes to an abnormal end, all RPC servers on the host must be restarted.
The nfsd is a common RPC server.
TCP/IP provides a naming system that supports both flat and hierarchical network organizations so that users can use meaningful, easily remembered names instead of Internet addresses.
In flat TCP/IP networks, each machine on the network has a file (/etc/hosts) containing the name-to-Internet-address mapping information for every host on the network.
When TCP/IP networks become very large, as on the Internet, naming is divided hierarchically. Typically, the divisions follow the network's organization. In TCP/IP, hierarchical naming is known as the domain name system (DNS) and uses the DOMAIN protocol. The DOMAIN protocol is implemented by the named daemon in TCP/IP.
The default order in resolving host names is:
1. | BIND/DNS (named) |
2. | Network Information Service (NIS) |
3. | Local /etc/hosts file |
The default order can be overwritten by creating the configuration file, /etc/netsvc.conf and specifying the desired order. Both the default and /etc/netsvc.conf can be overwritten with the environment variable NSORDER.
You can override the default order by creating the /etc/netsvc.conf file with an entry. If /etc/netsvc.conf does not exist, the default will be as though you made the following entry:
hosts = bind,nis,local
You can override the default or the configuration file order by changing the NSORDER environment variable. If it is not set, the default will be as though you issued the command:
export NSORDER=bind,nis,local
The /etc/resolv.conf file defines Domain Name Protocol (DOMAIN) name-server information for local resolver routines. If the /etc/resolv.conf file does not exist, then BIND/DNS is considered to be not set up or running and, therefore, not available. The system will attempt name resolution using the default paths, the /etc/netsvc.conf file, or the NSORDER environment variable.
When you have problems resolving a host name, and you are using a name server, you should:
1. | Verify that you have a /etc/resolv.conf file specifying the correct domain name and Internet address of a name server. If you try to access a host by name with an incorrect entry in /etc/resolv.conf, and if the host is also not defined in /etc/hosts, you will get an error message, as shown in the following example: |
# ping olympus
0821-062 ping: host name olympus NOT FOUND
2.
3.
4.
The nslookup command queries domain name servers for information about various hosts and domains. The nslookup command is useful for determining host names of servers of systems on the Internet by IP address, host name, or domain. The nslookup command can be run as follows:
# nslookup [IPAddress | HostName]
For example, to determine the host name of the system with the IP address of 207.25.253.26, you would enter:
# nslookup 207.25.253.26
Server: dhcp001.itsc.austin.ibm.com
Address: 9.3.240.2
Name: service.boulder.ibm.com
Address: 207.25.253.26
In this example, the host name of the system with the IP address of 207.25.253.26 is service.boulder.ibm.com.
The nslookup command can also determine IP addresses of systems by host name. For example, to display the IP address of service.software.ibm.com, you would enter:
# nslookup service.software.ibm.com
Server: dhcp001.itsc.austin.ibm.com
Address: 9.3.240.2
Changing network adapters in a machine may require additional configuration steps after the basic hardware installation. Consider the following tasks as the additional steps required to configure a new adapter.
1. | If you missed the informational messages from the cfgmgr command invoked during system boot, you should invoke the command again to check if the required device-dependent software is missing. |
2. | Install the required device software, if needed using the smitty devices command. |
3. | Invoke the diag -a command to confirm that the new adapter resource is added in the hardware configuration. |
4. | Rerun cfgmgr. |
5. | Ensure that the adapter is available on the system by invoking the lsdev -Cl command on the adapter. For example: |
# lsdev -Cl ent0
6. | Obtain the IP address and netmask from your network architect. |
7. | Configure the network interface using the SMIT fast path smit inet. Do not use smit mktcpip. It is only used for configuring TCP/IP for the first time. |
8. | Enable IP forwarding if the machine is connected to two networks. |
9. | Add a route to those systems that need access from any private networks. |
Non-authoritative answer:
Name: service.boulder.ibm.com
Address: 207.25.253.26
Aliases: service.software.ibm.com
In this example, the IP address of service.software.ibm.com is 207.25.253.26. The nslookup output also shows that service.software.ibm.com is an alias for service.boulder.ibm.com.
To change advanced features of network adapters, including ring speed, duplex settings, and queue sizes for transmitting and receiving information, use the SMIT fast path smit chgenet for Ethernet adapters, and smit chgtok for token ring adapters
The SMIT fast path command used to configure TCP/IP is smit tcpip. You can configure a network interface using the fast path smit inet. For these examples, we will be using an Ethernet interface, en0.
1.
Press Enter to select en0 and fill in the following dialog screen.
Choose the interface that you need to configure and fill in the necessary information
Press Enter to select en0 and fill in the following dialog screen.
Choose the interface that you need to configure and fill in the necessary information
To allow other systems to access a different network through a machine containing two network adapters, you must enable IP forwarding on that machine. The system will now act as a gateway between network A and network B.
IP forwarding is a runtime attribute. The default value of 0 (zero) prevents forwarding of IP packets when they are not for the local system. A value of 1 (one) enables forwarding. Enable IP forwarding using the command:
no -o ipforwarding=1
This setting will be lost following a system reboot.
For those systems that need to access a private network, use the SMIT fast path smit route or smit mkroute to add a route to the private network through the gateway between two networks
If you are moving your machine from one network segment to another, and need to change IP addresses, use smit mktcpip the same way as the first time you configured TCP/IP. You may need to change the host name, IP address, and the default gateway address.
The ifconfig command can allow you to configure and modify properties of network interfaces directly, without the use of SMIT. Often, administrators find this easier than using the SMIT panels for network administration.
The syntax of the ifconfig command for configuring and modifying network interfaces is as follows:
ifconfig Interface [ AddressFamily [ Address [ DestinationAddress ] ] [Parameters... ] ]
There are three address families that can be used with the ifconfig command:
Before you use the ifconfig command to perform administration on network interfaces, it is helpful to identify all interfaces on your server. There are two ways to identify network interfaces on your server. The first command that you can run is:
# lsdev -Cc if
This will produce a simple list of all interfaces on the system, whether they are being actively used by the system or not. For example:
# lsdev -Cc if
en0 Defined 10-80 Standard Ethernet Network Interface
en1 Defined 20-60 Standard Ethernet Network Interface
et0 Defined 10-80 IEEE 802.3 Ethernet Network Interface
et1 Defined 20-60 IEEE 802.3 Ethernet Network Interface
lo0 Available Loopback Network Interface
tr0 Available 10-68 Token Ring Network Interface
The second command that you can run is:
# ifconfig -a
This will produce a list of all network interfaces on the system that have IP addresses assigned and are actively being used by the system. For example:
# ifconfig -a
tr0: flags=e0a0043<UP,BROADCAST,RUNNING,ALLCAST,MULTICAST,GROUPRT,64BIT>
inet 10.1.2.2 netmask 0xffffff00 broadcast 10.1.2.255
lo0: flags=e08084b<UP,BROADCAST,LOOPBACK,RUNNING,SIMPLEX,MULTICAST,GROUPRT,64BIT
>
inet 127.0.0.1 netmask 0xff000000 broadcast 127.255.255.255
inet6 ::1/0
To get information about one specific network interface, including state, IP address, and netmask, run the command:
# ifconfig Interface
To get information about tr0, for example, run the command:
# ifconfig tr0
tr0: flags=e0a0043<UP,BROADCAST,RUNNING,ALLCAST,MULTICAST,GROUPRT,64BIT>
inet 10.1.2.2 netmask 0xffffff00 broadcast 10.1.2.255
Before messages can be transmitted through a network interface, the interface must be placed in the up or active state. To activate an interface using ifconfig, run the command:
# ifconfig Interface [Address] [netmask Netmask] up
To activate a network interface using ifconfig, such as tr0, run the command:
# ifconfig tr0 up
To activate a network interface, such as the loopback interface (lo0) and assign it an IP address, run the command:
# ifconfig lo0 127.0.0.1 up
To activate a network interface, such as a token ring interface (tr0), and assign it an IP address and netmask, run the command:
# ifconfig tr0 10.1.2.3 netmask 255.255.255.0 up
To stop messages from being transmitted through an interface, the interface must be placed in the down or inactive state. To deactivate an interface using ifconfig, run the command:
# ifconfig Interface down
For example, to deactivate the network interface tr0, run the command:
# ifconfig tr0 down
To remove a network address from an interface, the address must be deleted from the interface definition. To delete a network address from an interface using ifconfig, run the command:
# ifconfig Interface [Address] [netmask Netmask] delete
For example, to delete the network address from tr0, run the command:
# ifconfig tr0 delete
To remove an interface from the network interface list, the interface must be detached from the system. This command can be used when a network interface card has physically been removed from a system or when an interface no longer needs to be defined within the system. To detach a network interface from the system using ifconfig, run the command:
# ifconfig Interface detach
For example, to remove the interface tr0 from the network interface list, run the command:
# ifconfig tr0 detach
Note: This command removes all network addresses assigned to the interface and removes the interface from the output of the ifconfig -a command. To add an interface back to the system, or to add a new interface to the network interface list, run the command:
# ifconfig Interface
where Interface is the network interface you want to add.
Through the ifconfig command, you can bind multiple network addresses to a single network interface by defining an alias. This is a useful tool for such activities as providing two different initial home pages through a Web server application. To bind an alias to a network interface, run the command:
# ifconfig Interface Address [netmask Netmask] alias
For example, to bind the IP address of 10.1.2.3 to tr0 with a netmask of 255.255.255.0, run the command:
# ifconfig tr0 10.1.2.3 netmask 255.255.255.0 alias
Note: There will be no ODM record created of the alias by this command. You will need to invoke the same command every time you reboot your system to preserve the alias. If your system configuration has a local startup script defined in the /etc/inittab file, this command should be included in that local startup script.
When this alias is no longer required, you can remove it using the command:
ifconfig tr0 10.1.2.3 netmask 255.255.255.0 delete
Note: If you do not specify which alias is to be removed from a network interface, the system will default and remove the primary network address from the interface. After this occurs, the first alias in the list of network addresses for the interface will become the primary network address for the interface. To remove all aliases from an interface, you must delete each alias individually. Changing the MTU size of a network interfaceWhen messages are transmitted through a network interface, they travel in bundles of information called packets. These packets can vary in length from 60 bytes to 65535 bytes per packet. By default, a 16 Mb token-ring interface will transmit packets that are 1492 bytes long, and Ethernet interfaces will transmit packets that are 1500 bytes long. For AIX systems, these packets are governed by the maximum transmission unit (MTU) size variable. Note: The minimum and maximum MTU sizes for specific interfaces may vary. See "Automatic Configuration of Network Interfaces" in the AIX 5L Version 5.1 System Management Guide: Communications and Networks as part of the AIX product documentation for more information. |
The MTU size is critical for proper network communications. Packets that are too small in length may be lost during transmission. Packets that are too long in length may collide with other packets that are being transmitted. These factors can lead to slower transmission rates and other network problems as packets must then be retransmitted.
To determine the MTU size for a network interface, run the command:
# lsattr -El Interface
The output will look similar to the following:
# lsattr -El tr1
mtu 1492 Maximum IP Packet Size for This Device True
mtu_4 1492 Maximum IP Packet Size for 4 Mbit ring speed True
mtu_16 1492 Maximum IP Packet Size for 16 Mbit ring speed True
mtu_100 1492 Maximum IP Packet Size for 100 Mbit ring speed True
...
The ifconfig command can adjust the MTU size for a network interface. To change the MTU size, run the command:
# ifconfig Interface mtu Value
For example, to change the MTU size of tr1 to 12000 bytes in length, run the command:
# ifconfig tr1 mtu 12000
Note: The MTU size cannot be changed while the interface is in use. All systems that are on the same local area network (LAN) must have the same MTU size, so all systems must change MTU size simultaneously to prevent problems.
By default, FTP does not log connections or file transfers from users accessing the system. This can be a security risk when users use anonymous FTP to transfer files to or from your system. To enable FTP logging, do the following:
1. | Edit the /etc/syslog.conf file and add the line: |
daemon.info FileName
where FileName is the name of the log file that will track FTP activity, both by the anonymous and other user IDs. FileName must exist before you perform the next step of this process.
2. | Run the command refresh -s syslogd to refresh the syslogd daemon. |
3. | Edit the /etc/inetd.conf file, and modify the line containing ftpd as follows: |
ftp stream tcp6 nowait root /usr/sbin/ftpd ftpd -l
4. | Run the command refresh -s inetd to refresh the inetd daemon. |
When users use the ftp command to access your system, their login and file transfer activity will be logged in FileName. This log will look similar to the following:
Sep 5 13:56:47 localhost ftpd[17958]: connection from server2.example.ibm.com at Wed Sep 5 13:56:47 2001
Sep 5 13:56:52 localhost ftpd[17958]: ANONYMOUS FTP LOGIN FROM server2.example.ibm.com, [email protected]
Sep 5 13:57:17 localhost ftpd[17958]: FTPD: IMPORT file local testfile, remote
In this sample, a user established an anonymous FTP connection from server1.example.ibm.com. As a password, the user provided the e-mail address of [email protected]. The user used the FTP command put to upload the file testfile to server2.
FTP logging does not record when a user quits an FTP session. To determine if someone is still logged onto your system, run a ps -fp on the PID provided within the brackets ([17958]).
FTP log files will grow in proportion to how many users access your system and how many file transfers take place. We recommend that you monitor the growth of your FTP log to prevent potential system problems.
Apart from the hostname command, you can also use the uname -n command to display the host name of your system. Without any flags, the uname command will display the operating system that your are using.
You can also use the uname -x command to display:
The operating system that your are using |
The host name |
The machine ID number of the hardware running the system |
The release number of the operating system |
The operating system version |
The system model name |
When a user informs you that a certain system cannot be accessed, check for various network problems. Typically, you will go through these TCP/IP problem determination topics using whichever is applicable to your environment:
Communication problems |
Name resolution problems |
Routing problems |
Problems with System Resource Controller (SRC) support |
Telnet or rlogin problems |
Configuration problems |
Common problems with network interfaces |
Problems with packet delivery |
Problems with Dynamic Host Configuration Protocol (DHCP) |
However, there are other considerations outside the network area that you should check also:
The server system may be down. |
This will usually reveal itself when you check for communication problems. The ping command will lead you to the problem system. The whole system may be down or the network interface may be down.
The paging space may be full. |
If a user has logged in, this will be fairly obvious as there is usually a system message stating not enough paging space or not enough memory. However, if a user is trying to telnet or ftp to the system, there will be time outs as the system cannot create additional processes, or the system may be busy killing processes.
A file system may be full. |
If the user can access the system, but there are problems with certain functions, you should check all areas in the system. If the user cannot start the Web Based System Manager (WSM), the /tmp filesystem may be full.
A file system may not have been mounted. |
Usually, the user will mention losing all his files.
Not all problems are caused by the network and the network function. Make sure you understand your user's problem before concluding that it is a network problem.
The following are additional questions created by the authors to further test your understanding of the topics.
1. | Which of the following actions allow a System Administrator to configure anonymous FTP? |
A. smit ftp |
B. /usr/samples/tcpip/anon.ftp |
C. startsrc -s ftp -a anonymous |
D. add the FTP anonymous user using smit |
2. | A System Administrator is given only one Ethernet network card (en0) in a system, with an IP address of 192.168.1.3. A user wants to host two different initial home pages on the Web server. The System Administrator has verified that the Web server does support multiple IP Addresses. To add another IP address to the already configured interface, which of the following choices should be selected? |
A. smitty chgenet |
B. smitty add_interface |
C. ifconfig en0 newipaddress netmask netmask alias |
D. This task cannot be accomplished without adding a new Ethernet interface. |
3. | When a RPC (remote procedural call) server starts up, it registers itself with which of the following daemons? |
A. yp daemons |
B. nfs daemons |
C. inetd daemons |
D. portmap daemon |
The following are additional questions created by the authors to further test your understanding of the topics.
1. | Which of the following actions will allow the system administrator to stop and restart the TCP/IP daemons manually? |
A. Use the netstat command. |
B. Use the SRC utility to stop and restart. |
C. Use the netconfig utility menu. |
D. Issue the rmdev command on the appropriate network adapter. |
2. | Two Web servers need to be configured on a single machine that has only one network interface. Each Web server needs to have its own unique IP address. How should an administrator accomplish this? |
A. Use the smitty alias command |
B. Add it in /etc/defaults |
C. Use the newaliases 192.127.10.10 command |
D Use the ifconfig en0 192.127.10.10 alias command |
|
Switchboard | ||||
Latest | |||||
Past week | |||||
Past month |
startsrc [ -a Argument] [ -e Environment] [ -h Host] { -s Subsystem | -g Group}
To Start a Subserver
startsrc [ -h Host] -t Type [ -o Object] [ -p SubsystemPID]
Description
The startsrc command sends the System Resource Controller (SRC) a request to start a subsystem or a group of subsystems, or to pass on a packet to the subsystem that starts a subserver.
If a start subserver request is passed to the SRC and the subsystem to which the subserver belongs is not currently active, the SRC starts the subsystem and transmits the start subserver request to the subsystem.
Flags
Security
Attention RBAC users and Trusted AIX users: This command can perform privileged operations. Only privileged users can run privileged operations. For more information about authorizations and privileges, see Privileged Command Database in Security. For a list of privileges and the authorizations associated with this command, see the lssecattr command or the getcmdattr subcommand.
Examples
- To start a subsystem with arguments and environment variables, enter: This starts the srctest subsystem with "TERM=dumb", "HOME=/tmp" in its environment and "-D DEBUG" as two arguments to the subsystem.
- To start a subsystem group on a foreign host, enter: This starts all the subsystems in the subsystem tcpip group on the zork machine.
- To start a subserver, enter:
startsrc -t tester
This sends a start subserver request to the subsystem that owns the tester subsystem.
- To start a subsystem with command arguments, enter: This places "-a" as the first argument, "123" as the second, "-b" as the third, and"456" as the fourth argument to the srctest subsystem.
Files
Related Information
The stopsrc command, the refresh command.
The System resource controller in Operating system and device management gives an explanation of subsystems, subservers, and the System Resource Controller.
The Trusted AIX in Security
lssrc [ -h Host ] -a
To Get Group Status
lssrc [ -h Host ] -g GroupName
To Get Subsystem Status
lssrc [ -h Host ] [ -l ] -s Subsystem
To Get Status by PID
lssrc [ -h Host ] [ -l ] -p SubsystemPID
To Get Subserver Status
lssrc [ -h Host ] [ -l ] -t Type [ -p SubsystemPID ] [ -o Object ] [ -P
SubserverPID ]To Get Subsystem Status in SMIT Format
lssrc -S [ -s Subsystem | -d ]
1.TCP/IP related daemon startup script
/etc/rc.tcpip2.To view the route table
netstat -r3.To view the route table from the ODM DB
lsattr -EHl inet0 -a route4.Temporarily add a default route
route add default 192.168.1.15.Temporarily add an address to an interface
ifconfig en0 192.168.1.2 netmask 255.255.255.06.Temporarily add an alias to an interface
ifconfig en0 192.168.1.3 netmask 255.255.255.0 alias7.To permanently add an IP address to the en1 interface
chdev -l en1 -a netaddr=192.168.1.1 -a netmask=0xffffff008.Permanently add an alias to an interface
chdev -l en0 -a alias4=192.168.1.3,255.255.255.09.Remove a permanently added alias from an interface
chdev -l en0 -a delalias4=192.168.1.3,255.255.255.010.List ODM (next boot) IP con guration for interface
lsattr -El en011.Permanently set the hostname
chdev -l inet0 -a hostname=www.tablesace.net12.Turn on routing by putting this in rc.net
no -o ipforwarding=113.List networking devices
lsdev -Cc tcpip14.List Network Interfaces
lsdev -Cc if15.List attributes of inet0
lsattr -Ehl inet016.List (physical layer) attributes of ent0
lsattr -El ent017.List (networking layer) attributes of en0
lsattr -El en018.Speed is found through the entX device
lsattr -El ent0 -a media speed19.Set the ent0 link to Gig full duplex
(Auto Negotiation is another option)
chdev -l ent0 -a media speed=1000 Full Duplex -P20.Turn off Interface Speci c Network Options
no -p -o use isno=021.Get (long) statistics for the ent0 device (no -d is shorter)
entstat -d ent0javascript:void(0)
Save Now22.List all open, and in use TCP and UDP ports
netstat -anf inet23.List all LISTENing TCP ports
netstat -na | grep LISTEN
developerWorks AIX and UNIX AIX Networking
|
Society
Groupthink : Two Party System as Polyarchy : Corruption of Regulators : Bureaucracies : Understanding Micromanagers and Control Freaks : Toxic Managers : Harvard Mafia : Diplomatic Communication : Surviving a Bad Performance Review : Insufficient Retirement Funds as Immanent Problem of Neoliberal Regime : PseudoScience : Who Rules America : Neoliberalism : The Iron Law of Oligarchy : Libertarian Philosophy
Quotes
War and Peace : Skeptical Finance : John Kenneth Galbraith :Talleyrand : Oscar Wilde : Otto Von Bismarck : Keynes : George Carlin : Skeptics : Propaganda : SE quotes : Language Design and Programming Quotes : Random IT-related quotes : Somerset Maugham : Marcus Aurelius : Kurt Vonnegut : Eric Hoffer : Winston Churchill : Napoleon Bonaparte : Ambrose Bierce : Bernard Shaw : Mark Twain Quotes
Bulletin:
Vol 25, No.12 (December, 2013) Rational Fools vs. Efficient Crooks The efficient markets hypothesis : Political Skeptic Bulletin, 2013 : Unemployment Bulletin, 2010 : Vol 23, No.10 (October, 2011) An observation about corporate security departments : Slightly Skeptical Euromaydan Chronicles, June 2014 : Greenspan legacy bulletin, 2008 : Vol 25, No.10 (October, 2013) Cryptolocker Trojan (Win32/Crilock.A) : Vol 25, No.08 (August, 2013) Cloud providers as intelligence collection hubs : Financial Humor Bulletin, 2010 : Inequality Bulletin, 2009 : Financial Humor Bulletin, 2008 : Copyleft Problems Bulletin, 2004 : Financial Humor Bulletin, 2011 : Energy Bulletin, 2010 : Malware Protection Bulletin, 2010 : Vol 26, No.1 (January, 2013) Object-Oriented Cult : Political Skeptic Bulletin, 2011 : Vol 23, No.11 (November, 2011) Softpanorama classification of sysadmin horror stories : Vol 25, No.05 (May, 2013) Corporate bullshit as a communication method : Vol 25, No.06 (June, 2013) A Note on the Relationship of Brooks Law and Conway Law
History:
Fifty glorious years (1950-2000): the triumph of the US computer engineering : Donald Knuth : TAoCP and its Influence of Computer Science : Richard Stallman : Linus Torvalds : Larry Wall : John K. Ousterhout : CTSS : Multix OS Unix History : Unix shell history : VI editor : History of pipes concept : Solaris : MS DOS : Programming Languages History : PL/1 : Simula 67 : C : History of GCC development : Scripting Languages : Perl history : OS History : Mail : DNS : SSH : CPU Instruction Sets : SPARC systems 1987-2006 : Norton Commander : Norton Utilities : Norton Ghost : Frontpage history : Malware Defense History : GNU Screen : OSS early history
Classic books:
The Peter Principle : Parkinson Law : 1984 : The Mythical Man-Month : How to Solve It by George Polya : The Art of Computer Programming : The Elements of Programming Style : The Unix Hater’s Handbook : The Jargon file : The True Believer : Programming Pearls : The Good Soldier Svejk : The Power Elite
Most popular humor pages:
Manifest of the Softpanorama IT Slacker Society : Ten Commandments of the IT Slackers Society : Computer Humor Collection : BSD Logo Story : The Cuckoo's Egg : IT Slang : C++ Humor : ARE YOU A BBS ADDICT? : The Perl Purity Test : Object oriented programmers of all nations : Financial Humor : Financial Humor Bulletin, 2008 : Financial Humor Bulletin, 2010 : The Most Comprehensive Collection of Editor-related Humor : Programming Language Humor : Goldman Sachs related humor : Greenspan humor : C Humor : Scripting Humor : Real Programmers Humor : Web Humor : GPL-related Humor : OFM Humor : Politically Incorrect Humor : IDS Humor : "Linux Sucks" Humor : Russian Musical Humor : Best Russian Programmer Humor : Microsoft plans to buy Catholic Church : Richard Stallman Related Humor : Admin Humor : Perl-related Humor : Linus Torvalds Related humor : PseudoScience Related Humor : Networking Humor : Shell Humor : Financial Humor Bulletin, 2011 : Financial Humor Bulletin, 2012 : Financial Humor Bulletin, 2013 : Java Humor : Software Engineering Humor : Sun Solaris Related Humor : Education Humor : IBM Humor : Assembler-related Humor : VIM Humor : Computer Viruses Humor : Bright tomorrow is rescheduled to a day after tomorrow : Classic Computer Humor
The Last but not Least Technology is dominated by two types of people: those who understand what they do not manage and those who manage what they do not understand ~Archibald Putt. Ph.D
Copyright © 1996-2021 by Softpanorama Society. www.softpanorama.org was initially created as a service to the (now defunct) UN Sustainable Development Networking Programme (SDNP) without any remuneration. This document is an industrial compilation designed and created exclusively for educational use and is distributed under the Softpanorama Content License. Original materials copyright belong to respective owners. Quotes are made for educational purposes only in compliance with the fair use doctrine.
FAIR USE NOTICE This site contains copyrighted material the use of which has not always been specifically authorized by the copyright owner. We are making such material available to advance understanding of computer science, IT technology, economic, scientific, and social issues. We believe this constitutes a 'fair use' of any such copyrighted material as provided by section 107 of the US Copyright Law according to which such material can be distributed without profit exclusively for research and educational purposes.
This is a Spartan WHYFF (We Help You For Free) site written by people for whom English is not a native language. Grammar and spelling errors should be expected. The site contain some broken links as it develops like a living tree...
|
You can use PayPal to to buy a cup of coffee for authors of this site |
Disclaimer:
The statements, views and opinions presented on this web page are those of the author (or referenced source) and are not endorsed by, nor do they necessarily reflect, the opinions of the Softpanorama society. We do not warrant the correctness of the information provided or its fitness for any purpose. The site uses AdSense so you need to be aware of Google privacy policy. You you do not want to be tracked by Google please disable Javascript for this site. This site is perfectly usable without Javascript.
Last modified: March 12, 2019